Back to overview
Downtime
FoxyLearning Helpdesk (https://help.foxylearning.com) and CEUniverse Helpdesk (https://help.ceuniverse.com) are down
Oct 30 at 07:30pm PDT
Affected services
FoxyLearning Helpdesk (https://help.foxylearning.com)
CEUniverse Helpdesk (https://help.ceuniverse.com)
Resolved
Oct 31 at 01:23am PDT
FoxyLearning Helpdesk (https://help.foxylearning.com) and CEUniverse Helpdesk (https://help.ceuniverse.com) recovered.
Affected services
FoxyLearning Helpdesk (https://help.foxylearning.com)
CEUniverse Helpdesk (https://help.ceuniverse.com)
Created
Oct 30 at 07:30pm PDT
FoxyLearning Helpdesk (https://help.foxylearning.com) and CEUniverse Helpdesk (https://help.ceuniverse.com) went down.
Affected services
FoxyLearning Helpdesk (https://help.foxylearning.com)
CEUniverse Helpdesk (https://help.ceuniverse.com)