Back to overview
Downtime
FoxyLearning Helpdesk (https://help.foxylearning.com) and CEUniverse Helpdesk (https://help.ceuniverse.com) are down
Nov 14 at 04:34am PST
Affected services
FoxyLearning Helpdesk (https://help.foxylearning.com)
CEUniverse Helpdesk (https://help.ceuniverse.com)
Resolved
Nov 14 at 04:42am PST
FoxyLearning Helpdesk (https://help.foxylearning.com) and CEUniverse Helpdesk (https://help.ceuniverse.com) recovered.
Affected services
FoxyLearning Helpdesk (https://help.foxylearning.com)
CEUniverse Helpdesk (https://help.ceuniverse.com)
Created
Nov 14 at 04:34am PST
FoxyLearning Helpdesk (https://help.foxylearning.com) and CEUniverse Helpdesk (https://help.ceuniverse.com) went down.
Affected services
FoxyLearning Helpdesk (https://help.foxylearning.com)
CEUniverse Helpdesk (https://help.ceuniverse.com)