Back to overview
Downtime

FoxyLearning Helpdesk (https://help.foxylearning.com) is down

Dec 04 at 09:41pm PST
Affected services
FoxyLearning Helpdesk (https://help.foxylearning.com)

Resolved
Dec 05 at 01:26am PST

FoxyLearning Helpdesk (https://help.foxylearning.com) recovered.

Created
Dec 04 at 09:41pm PST

FoxyLearning Helpdesk (https://help.foxylearning.com) and CEUniverse Helpdesk (https://help.ceuniverse.com) went down.